作者:手机用户2602897337 | 来源:互联网 | 2024-12-22 15:15
在本次实验中,我们将通过配置 Nginx 实现反向代理和负载均衡。具体目标是从北京的本地代理服务器访问位于上海的 Web 服务器,并在浏览器输入 www.jht.com 后,依次显示红、黄、绿三种颜色页面,以此来验证负载均衡的效果。
R1 路由器配置如下:
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
no sh
interface Ethernet0/1
ip address 10.1.1.1 255.255.255.0
ip nat outside
no sh
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface Ethernet0/1 overload
R2 路由器配置,将 Nginx 服务器的 8081、8082 和 8083 端口映射出去。
interface Ethernet0/0
ip address 192.168.56.1 255.255.255.0
ip nat inside
no sh
interface Ethernet0/1
ip address 10.1.1.2 255.255.255.0
ip nat outside
no sh
ip nat inside source static tcp 192.168.56.102 8081 10.1.1.2 8081 extendable
ip nat inside source static tcp 192.168.56.102 8082 10.1.1.2 8082 extendable
ip nat inside source static tcp 192.168.56.102 8083 10.1.1.2 8083 extendable
接下来是 Nginx 服务器的配置:
1. 安装 Nginx
//安装基本依赖包
[root@Nginx ~]# yum install -y gcc gcc-c++ autoconf pcre pcre-devel make automake wget httpd-tools vim tree
配置 Nginx 官方 Yum 源
[root@Nginx ~]# vi /etc/yum.repos.d/nginx.repo
[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/centos/6/$basearch/
gpgcheck=0
enabled=1
//安装 Nginx
[root@Nginx ~]# yum install nginx -y
//查看 Nginx 当前版本
[root@Nginx ~]# nginx -v
nginx version: nginx/1.12.2
2. 创建相应的目录,并创建对应的 HTML 文件
[root@Nginx ~]# mkdir /soft/{code1,code2,code3} -p
[root@Nginx ~]# cat /soft/code1/index.html
jht1-8081
[root@Nginx ~]# cat /soft/code2/index.html
jht1-8082
[root@Nginx ~]# cat /soft/code3/index.html
jht1-8083
3. 建立对应的 releserver.conf 配置文件
[root@Nginx ~]# cat /etc/nginx/conf.d/releserver.conf
server {
listen 8081;
root /soft/code1;
index index.html;
}
server {
listen 8082;
root /soft/code2;
index index.html;
}
server {
listen 8083;
root /soft/code3;
index index.html;
}
最后是代理服务器的配置:
1. 安装 Nginx
//安装基本依赖包
[root@Nginx ~]# yum install -y gcc gcc-c++ autoconf pcre pcre-devel make automake wget httpd-tools vim tree
配置 Nginx 官方 Yum 源
[root@Nginx ~]# vi /etc/yum.repos.d/nginx.repo
[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/centos/6/$basearch/
gpgcheck=0
enabled=1
//安装 Nginx
[root@Nginx ~]# yum install nginx -y
//查看 Nginx 当前版本
[root@Nginx ~]# nginx -v
nginx version: nginx/1.12.2
2. 配置 Nginx 反向代理
[root@Nginx ~]# cat /etc/nginx/conf.d/proxy.conf
upstream node {
server 10.1.1.2:8081;
server 10.1.1.2:8082;
server 10.1.1.2:8083;
}
server {
server_name www.jht.com;
index index.html
listen 80;
location / {
proxy_pass http://node;
}
}
3. 使用浏览器验证结果