作者:mobiledu2502859233 | 来源:互联网 | 2024-12-16 01:43
1、进入特权模式与全局配置模式
Switch> enable //进入特权模式
Switch# configure terminal //进入全局配置模式
Switch(config)# hostname cisco-sw1 //设置交换机名称
cisco-sw1(config)# enable password cisco //设置明文特权模式密码
cisco-sw1(config)# enable secret ciscoswitch //设置加密特权模式密码
2、配置VLAN并分配端口
cisco-sw1(config)# vlan 2 //创建VLAN 2
cisco-sw1(config-vlan)# name test //命名VLAN
cisco-sw1(config-vlan)# exit
cisco-sw1(config)# interface fastethernet 0/1 //选择端口
cisco-sw1(config-if)# switchport mode access //设置端口为接入模式
cisco-sw1(config-if)# switchport access vlan 2 //将端口分配给VLAN 2
3、访问特定端口
switch> enable
switch# configure terminal
switch(config)# interface fastethernet 0/1 //进入指定端口配置模式
4、使用show命令查看配置
switch> enable
switch# show version //显示系统版本信息
switch# show vlan id 1 //显示VLAN 1的信息
switch# show running-config //显示当前运行配置
switch# show interfaces fastethernet 0/1 //显示FastEthernet 0/1接口的详细信息
switch# show mac address-table //显示MAC地址表
5、重置交换机至出厂设置
switch> enable
switch# erase startup-config //删除启动配置文件
switch# reload //重启设备
6、配置Telnet远程访问
switch> enable
switch# configure terminal
switch(config)# enable password cisco //设置特权模式密码
switch(config)# interface vlan 1 //选择用于远程访问的VLAN接口
switch(config-if)# ip address 192.168.1.1 255.255.255.0 //配置IP地址
switch(config-if)# no shutdown //启用接口
switch(config-if)# exit
switch(config)# line vty 0 4 //允许0-4个远程连接
switch(config-line)# password 123456 //设置远程访问密码
switch(config-line)# login //启用远程登录功能
7、配置SSH远程访问
switch> enable
switch# configure terminal
switch(config)# hostname cisco-sw1 //设置主机名
cisco-sw1(config)# ip domain-name cisco.com //配置域名
cisco-sw1(config)# line vty 0 4
cisco-sw1(config-line)# transport input ssh //设置SSH为远程登录协议
cisco-sw1(config-line)# exit
cisco-sw1(config)# crypto key generate rsa //生成RSA密钥对,用于SSH加密通信