作者:康博洋2602899791 | 来源:互联网 | 2023-10-12 15:54
数据结构实验之链表七:单链表中重复元素的删除ProblemDescription按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输
数据结构实验之链表七:单链表中重复元素的删除
Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。
Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Example Input
10
21 30 14 55 32 63 11 30 55 30
Example Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
代码:
#include <stdio.h>
#include <stdlib.h>
typedef struct list
{
int data;
struct list* next;
}LIST;
int main()
{
LIST *L=(LIST *)malloc(sizeof(LIST));
LIST *p,*q,*pre,*s;
L->next=NULL;
int n,t;
scanf("%d",&n);
t=n;
while(n--)
{
s=(LIST *)malloc(sizeof(LIST));
scanf("%d",&s->data);
s->next=L->next;
L->next=s;
}
printf("%d\n",t);
p=L->next;
while(p)
{
if(p->next==NULL)
printf("%d",p->data);
else
printf("%d ",p->data);
p=p->next;
}
printf("\n");
p=L->next;
while(p)
{
pre=p;
q=p->next;
while(q)
{
if(p->data==q->data)
{
pre->next=q->next;
free(q);
q=pre->next;
t--;
}else{
pre=q;
q=q->next;
}
}
p=p->next;
}
printf("%d\n",t);
p=L->next;
while(p)
{
if(p->next==NULL)
printf("%d",p->data);
else
printf("%d ",p->data);
p=p->next;
}
return 0;
}